Removing an address from your autocomplete list in Outlook

Clearing the Outlook 2016 Auto-Complete Cache (E-mail Cache)

How to Clear Out Individual Entries:

1. In the Outlook main window, start a new email by clicking the New Email button.

Select the "New Email" button in Outlook 2016.
 

2. In the new email To field, start typing the email address or the name of the contact you would like to clear from the Auto-Complete cache. It appears listed in a tool-tip.

3. Press the down arrow key to select the right contact if there are more than one proposed. 

4. Click the delete (X) icon next to the suggestion to permanently remove the Auto-Complete entry.

click the "Delete" icon next to the auto complete suggestion.
 

How to Clear the Whole Auto-Complete Cache:

1. In the Outlook main window, click the File menu.

Click the "File" tab in the Outlook 2016 ribbon.
 

2. From the File menu, click the Options button.

click the Options tab on the sidebar
 

3. In the Options, click the Mail tab and scroll down to the Send Messages section.

In the Mail tab, view the Send Messages section of the page
 

4. Click the Empty Auto-Complete List button.

5. A confirmation box will appear, click Yes. The Auto-Complete cache will be completely erased.

Select "yes in the Auto-Complete pop up window.

Add Feedback